Skip to content

Commit

Permalink
(misc/R-pillar) Updated 1.4.2 to 1.6.1
Browse files Browse the repository at this point in the history
# pillar 1.6.1

- Bump required versions of ellipsis and vctrs to avoid warning during package load.
- `obj_sum()` no longer includes shape twice (#315).


# pillar 1.6.0

## Features

- New `num()` and `char()` offer a flexible way to customize the display of numeric and character columns (#191, #84).
- New `"pillar.max_dec_width"` option (#308).
- New `format_type_sum.AsIs()` avoids the need to implement your own `format_type_sum()` method (#286).
- `align()` gains `space` argument to control the character used for filling (#285).
- Numbers in scientific and decimal notation are formatted with the same rules regarding significant or decimal digits (#297).

## Bug fixes

- Load the debugme package only if the `DEBUGME` environment variable is set.
- More accurate detection if the decimal dot is necessary, and how many digits to show after the decimal dot (#298).
- Use display width instead of number of characters when truncating character columns.

## Documentation

- New `vignette("numbers")` and `vignette("digits")` (#308).

## Internal

- Compatibility with vctrs 0.3.7 (#291).
- `format.pillar_shaft_simple()` requires `"na"` attribute and no longer defaults to `pillar_na()` (#273).


# pillar 1.5.1

## Features

- New `format_glimpse()` (#177).

## Bug fixes

- Color and formatting can now be reliably turned off by setting the `"cli.num_colors"` option to 1 (#269).

## Documentation

- Add examples for new functions (#264).
- Fix lifecycle badges everywhere.


# pillar 1.5.0

## Breaking changes

- `obj_sum()` now always returns a string. `pillar_shaft.list()` iterates over its elements and calls `obj_sum()` for each (#137).

- Breaking: `print.pillar()` and `print.pillar_ornament()` now show  `<pillar>` `<pillar_ornament>` in the first line (#227, #228).

- pillar has been re-licensed as MIT (#215).

## Extensibility

- New `size_sum()` generic (#239).

- New `ctl_new_pillar()` and `ctl_new_compound_pillar()` used via `print.tbl()`, `format.tbl()` and `tbl_format_setup.tbl()` (#230).

- New `new_pillar()` low-level constructor (#230).

- New `new_pillar_component()` and `pillar_component()` (#230).

- New articles `vignette("extending")` and `vignette("printing")` (#251).

## Formatting

- All printing code has been moved from tibble to pillar (#179), including `glimpse()` (#234). This concentrates the printing code in one package and allows for better extensibility.

- Improve formatting for `"Surv"` and `"Surv2"` classes from the survival package (#199).

- Vectors of the `vctrs_unspecified()` class are formatted better (#256).

- Arrays are now formatted by showing only their first slice (#142).

- Avoid wrapping extra column names with spaces (#254).

## Internal

- Now using debugme to simplify understand the complex control flow, see `vignette("debugme")` (#248).

- New `format.pillar_ornament()` (#228).

- Using testthat 3e (#218).

- Avoid pillar.bold option in most tests (#216).

- Change internal storage format for `colonnade()` and `extra_cols()` (#204).


# pillar 1.4.7

- Adapt to changed environment on CRAN's Solaris machine.


# pillar 1.4.6

- Restore compatibility with R 3.2.


# pillar 1.4.5

## Features

- New `pillar.min_chars` option allows controlling the minimum number of characters shown for a character column (#178, @statsmaths).

- `bit64::integer64()` columns are now formatted the same way as numeric columns (#175).

- New `align()` to support easy alignment of strings within a character vector (existing function exported by @davidchall, #185).

## Technical

- `pillar_shaft()`, `format_type_sum()` and `extra_cols()` issue a warning if dots are unused.

- `new_pillar_title()` and `new_pillar_type()` warn if `...` is not empty.

## Internal

- Use lifecycle package.

- Remove compatibility code for R < 3.3.


# pillar 1.4.4

- `obj_sum()` uses `vctrs::vec_size()` internally.

- `is_vector_s3.default()` is soft-deprecated and no longer used. Please ensure that `vctrs::vec_is()` is `TRUE` for your class.

- Rely on vctrs for type abbreviations.


# pillar 1.4.3

- `new_pillar_shaft_simple()` gains `na` argument to control appearance of `NA` values.

- String columns are quoted if at least one value needs quotes (#171).

- Apply subtle style to `list_of` columns (#172).

- Fix formatting if mantissa is very close to 1 (#174).

- Use `as.character()` instead of `as_character()`.

- Remove compatibility with testthat < 2.0.0.
  • Loading branch information
mef committed Jun 6, 2021
1 parent bfe5ed8 commit 7dc8a9c
Show file tree
Hide file tree
Showing 2 changed files with 14 additions and 7 deletions.
11 changes: 9 additions & 2 deletions misc/R-pillar/Makefile
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.5 2019/08/08 19:53:55 brook Exp $
# $NetBSD: Makefile,v 1.6 2021/06/06 23:37:31 mef Exp $

R_PKGNAME= pillar
R_PKGVER= 1.4.2
R_PKGVER= 1.6.1
CATEGORIES= misc

MAINTAINER= minskim@NetBSD.org
Expand All @@ -16,6 +16,13 @@ DEPENDS+= R-vctrs>=0.2.0:../../math/R-vctrs
DEPENDS+= R-utf8>=1.1.0:../../textproc/R-utf8
DEPENDS+= R-utf8>=1.1.3:../../textproc/R-utf8

# Packages suggested but not available:
# 'debugme', 'DiagrammeR','formattable', 'nycflights13',
# 'palmerpenguins'
TEST_DEPENDS+= R-dplyr-[0-9]*:../../math/R-dplyr
TEST_DEPENDS+= R-units-[0-9]*:../../math/R-units


USE_LANGUAGES= # none

.include "../../math/R/Makefile.extension"
Expand Down
10 changes: 5 additions & 5 deletions misc/R-pillar/distinfo
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.3 2019/07/31 20:42:03 brook Exp $
$NetBSD: distinfo,v 1.4 2021/06/06 23:37:31 mef Exp $

SHA1 (R/pillar_1.4.2.tar.gz) = 6af37a45b8539fed426eee850ceb460cf50799ac
RMD160 (R/pillar_1.4.2.tar.gz) = 9f0c696fc2a25de56d7f5a4e894b76005e7dda6c
SHA512 (R/pillar_1.4.2.tar.gz) = 6ec4f1cdb4c5ac80f549c7e388beec59605a85758b3e9c6e7845e3af74303d6c0c3b8dd30f435e4361a2b3c11247baba57008772bbf17049276b34af45212d08
Size (R/pillar_1.4.2.tar.gz) = 228815 bytes
SHA1 (R/pillar_1.6.1.tar.gz) = 0969f1ca7159cb00b623063faa50e9e421efcb1d
RMD160 (R/pillar_1.6.1.tar.gz) = 82d54afb2728b0b26915421d726772564b2fad5e
SHA512 (R/pillar_1.6.1.tar.gz) = f93ca2b1522f12621be241383ed589aadd1240d668d85d848413282c3c4dc5671bdef23dafeeb5613b6aa72ad9e0624289b8cec7cb1156fae25783baf16f2536
Size (R/pillar_1.6.1.tar.gz) = 1111747 bytes

0 comments on commit 7dc8a9c

Please sign in to comment.