Skip to content

Commit

Permalink
glibmm: update to 2.54.1.
Browse files Browse the repository at this point in the history
2.54.1 (stable):

Glib:
* Variant: Don't use std::index_sequence from C++14.
  (Kjell Ahlstedt, Jonathan Wakely) Bug #787648 (Armin K.)

Documentation:
* Note that Gio::Application::property_resource_base_path() shall not
  be used. It has a bug that's hard to fix without breaking ABI.
  (Kjell Ahlstedt) Bug #787496 (Daniel Boles)

gmmproc:
* Convert all property documentation to C++.
  (Kjell Ahlstedt) Bug #787698 (Daniel Boles)

2.54.0 (stable):

Glib:
* Added DBusObjectPathString and DBusSignatureString, for Variants with D-Bus object paths or D-Bus signatures,
  and add Variant specializations for Variant<Glib::DBusObjectPathString>,
  Variant<Glib::DBusSignatureString> and Variant<std::vector<Glib::DBusObjectPathString>>.
  (Kjell Ahlstedt) Bug #785700
* Variant: Add template specialization for std::tuple.
  (Alexander Rössler) Bug #777791

Gio:
* ActionGroup: Add optional action_name parameters to some signals.
  (Kjell Ahlstedt)
* Settings: Add optional key parameter to the writable_changed signal.
  (Kjell Ahlstedt)

gmmproc:
* Write signal flags to generated documentation
  (Kjell Ahlstedt) Bug #785895 (Daniel Boles)
* Write default values of properties to generated documentation
  (Kjell Ahlstedt) Bug #785895 (Daniel Boles)
* Warn for unmatched deprecations in signals and properties.
  (Kjell Ahlstedt)
* Accept curly braces in default values in _WRAP macros.
  (Kjell Ahlstedt) Bug #783216 comment #13 (Daniel Boles)
* Fix _WRAP_ENUM for enumerators with apostrophes.
  (Kjell Ahlstedt)
* Add new elements types for the docs_override:
  substitute_type_name and substitute_enumerator_name.
  (Kjell Ahlstedt) Bug #86864


2.52.1 (stable):

Gio:
* TlsDatabase: Fix memory leak in a vfunc.
  (Kjell Ahlstedt) Bug #783360

Documentation:
* Update docs of get_*_name().
  (Daniel Boles)

Build:
* MacOS: Really correct build without gdesktopinfo.
  (Kjell Ahlstedt) Bug #781947

2.52.0 (stable):

Gio:
* UnixSocketAddress::create(): Remove the default value for the type
  parameter to avoid ambiguity.
  (Kjell Ahlstedt) Bug #782592

Gio::DBus
* Proxy: Wrap call() and call_sync() methods.
  (Vyacheslav Yurkov) Bug #781818

Documentation:
* RefPtr: Clarify comment about undefined behaviour.
  (Daniel Boles)

2.51.7 (unstable):

Glib:
* SettingsSchemaKey: Add missing value/range methods.
  (Daniel Boles) Bug #774903
* Variant: Replace throw(std::bad_cast) with noexcept(false),
  to fix the build with C++17.
  See https://bugzilla.redhat.com/show_bug.cgi?id=1438766
  (Murray Cumming)
* VariantType: Deprecate first() and next(). Add get_item_types()
  (Kjell Ahlstedt) Bug #775741

Gio:
* ActionMap: Add add_action_with_parameter() that takes a parameter type,
  and deprecated the existing method, because it cannot work.
  (Daniel Boles) Bug #774444
* SimpleAction: Make set_state() public.
  (Daniel Boles) Bug #777953

Build:
* MacOS: Correct build without gdesktopinfo.
  (John Ralls) Bug #781947
* Glib::Object: Suppress deprecation warning for g_object_newv() with glib 2.54.
  (Kjell Ahlstedt)


2.51.6 (unstable):

This is version 2.51.6 of glibmm-2.24. Ignore versions 2.51.1 to 2.51.5 of
unstable glibmm-2.52. Unstable glibmm-2.52 is now unstable glibmm-2.54,
leaving the 2.51/52 version numbers again for use by stable glibmm-2.52.

Glib:
* Dispatcher:
  - autodeduce the type of the fd field.
  (Marcin Kolny) Bug #772074
  - Don't cast a HANDLE to an int on Windows.
  (Kjell Ahlstedt) Bug #772074
* ustring: Add cbegin() and cend().
  (Murray Cumming)

Gio:
* Action: Include variant.h in the heaer.
  (Daniel Boles) Bug #777953
* Application: get_default(): Correct the reference counting.
  (Kjell Ahlstedt) Bug #779936
* Settings:
  - Really add set_enum() and set_flags().
  (djb) Bug #774647
  - Writable-change-event signal: Correct the type of the key parameter.
  (Marcin Kolny) Bug #773977
* SettingsSchemaSource: get_default(): Correct the refcounting.
  (Marcin Kolny) Bug #774593

Gio::DBus:
* Proxy: Fix memory leak in get_cached_property_names().
  (Kjell Ahlstedt) Bug #775210

Documentation:
* Glib::Variant: Improve documentation of maybe types.
  (Daniel Boles) Bug #778219
* Gio::ActionMap: Clarify doc of ActivateWithParameterSlot
  (Daniel Boles)

Build:
* Visual Studio builds: "Install" the .pdb files
  (Chun-wei Fan)
  • Loading branch information
0-wiz-0 committed Nov 24, 2017
1 parent ba610d9 commit 9901225
Show file tree
Hide file tree
Showing 3 changed files with 33 additions and 12 deletions.
4 changes: 2 additions & 2 deletions devel/glibmm/Makefile
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.73 2017/08/01 14:58:56 wiz Exp $
# $NetBSD: Makefile,v 1.74 2017/11/24 15:14:50 wiz Exp $

DISTNAME= glibmm-2.50.1
DISTNAME= glibmm-2.54.1
CATEGORIES= devel gnome
MASTER_SITES= ${MASTER_SITE_GNOME:=sources/glibmm/${PKGVERSION_NOREV:R}/}
EXTRACT_SUFX= .tar.xz
Expand Down
31 changes: 26 additions & 5 deletions devel/glibmm/PLIST
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.37 2016/11/25 17:11:50 prlw1 Exp $
@comment $NetBSD: PLIST,v 1.38 2017/11/24 15:14:50 wiz Exp $
include/giomm-2.4/giomm.h
include/giomm-2.4/giomm/action.h
include/giomm-2.4/giomm/actiongroup.h
Expand Down Expand Up @@ -372,6 +372,7 @@ include/glibmm-2.4/glibmm/value_custom.h
include/glibmm-2.4/glibmm/valuearray.h
include/glibmm-2.4/glibmm/variant.h
include/glibmm-2.4/glibmm/variant_basictypes.h
include/glibmm-2.4/glibmm/variantdbusstring.h
include/glibmm-2.4/glibmm/variantdict.h
include/glibmm-2.4/glibmm/variantiter.h
include/glibmm-2.4/glibmm/varianttype.h
Expand Down Expand Up @@ -433,8 +434,6 @@ share/doc/glibmm-2.4/images/gtkmm_logo.gif
share/doc/glibmm-2.4/images/top.gif
share/doc/glibmm-2.4/reference/glibmm-2.4.tag
share/doc/glibmm-2.4/reference/html/annotated.html
share/doc/glibmm-2.4/reference/html/arrowdown.png
share/doc/glibmm-2.4/reference/html/arrowright.png
share/doc/glibmm-2.4/reference/html/bc_s.png
share/doc/glibmm-2.4/reference/html/bdwn.png
share/doc/glibmm-2.4/reference/html/classGio_1_1Action-members.html
Expand Down Expand Up @@ -874,6 +873,12 @@ share/doc/glibmm-2.4/reference/html/classGlib_1_1Container__Helpers_1_1SListIter
share/doc/glibmm-2.4/reference/html/classGlib_1_1ConvertError-members.html
share/doc/glibmm-2.4/reference/html/classGlib_1_1ConvertError.html
share/doc/glibmm-2.4/reference/html/classGlib_1_1ConvertError__inherit__graph.png
share/doc/glibmm-2.4/reference/html/classGlib_1_1DBusObjectPathString-members.html
share/doc/glibmm-2.4/reference/html/classGlib_1_1DBusObjectPathString.html
share/doc/glibmm-2.4/reference/html/classGlib_1_1DBusObjectPathString__inherit__graph.png
share/doc/glibmm-2.4/reference/html/classGlib_1_1DBusSignatureString-members.html
share/doc/glibmm-2.4/reference/html/classGlib_1_1DBusSignatureString.html
share/doc/glibmm-2.4/reference/html/classGlib_1_1DBusSignatureString__inherit__graph.png
share/doc/glibmm-2.4/reference/html/classGlib_1_1Date-members.html
share/doc/glibmm-2.4/reference/html/classGlib_1_1Date.html
share/doc/glibmm-2.4/reference/html/classGlib_1_1DateTime-members.html
Expand Down Expand Up @@ -1212,6 +1217,12 @@ share/doc/glibmm-2.4/reference/html/classGlib_1_1VariantStringBase.html
share/doc/glibmm-2.4/reference/html/classGlib_1_1VariantStringBase__inherit__graph.png
share/doc/glibmm-2.4/reference/html/classGlib_1_1VariantType-members.html
share/doc/glibmm-2.4/reference/html/classGlib_1_1VariantType.html
share/doc/glibmm-2.4/reference/html/classGlib_1_1Variant_3_01Glib_1_1DBusObjectPathString_01_4-members.html
share/doc/glibmm-2.4/reference/html/classGlib_1_1Variant_3_01Glib_1_1DBusObjectPathString_01_4.html
share/doc/glibmm-2.4/reference/html/classGlib_1_1Variant_3_01Glib_1_1DBusObjectPathString_01_4__inherit__graph.png
share/doc/glibmm-2.4/reference/html/classGlib_1_1Variant_3_01Glib_1_1DBusSignatureString_01_4-members.html
share/doc/glibmm-2.4/reference/html/classGlib_1_1Variant_3_01Glib_1_1DBusSignatureString_01_4.html
share/doc/glibmm-2.4/reference/html/classGlib_1_1Variant_3_01Glib_1_1DBusSignatureString_01_4__inherit__graph.png
share/doc/glibmm-2.4/reference/html/classGlib_1_1Variant_3_01Glib_1_1ustring_01_4-members.html
share/doc/glibmm-2.4/reference/html/classGlib_1_1Variant_3_01Glib_1_1ustring_01_4.html
share/doc/glibmm-2.4/reference/html/classGlib_1_1Variant_3_01Glib_1_1ustring_01_4__inherit__graph.png
Expand Down Expand Up @@ -1251,6 +1262,11 @@ share/doc/glibmm-2.4/reference/html/classGlib_1_1Variant_3_01std_1_1map_3_01K_00
share/doc/glibmm-2.4/reference/html/classGlib_1_1Variant_3_01std_1_1string_01_4-members.html
share/doc/glibmm-2.4/reference/html/classGlib_1_1Variant_3_01std_1_1string_01_4.html
share/doc/glibmm-2.4/reference/html/classGlib_1_1Variant_3_01std_1_1string_01_4__inherit__graph.png
share/doc/glibmm-2.4/reference/html/classGlib_1_1Variant_3_01std_1_1tuple_3_01Types_8_8_8_01_4_01_4-members.html
share/doc/glibmm-2.4/reference/html/classGlib_1_1Variant_3_01std_1_1tuple_3_01Types_8_8_8_01_4_01_4.html
share/doc/glibmm-2.4/reference/html/classGlib_1_1Variant_3_01std_1_1tuple_3_01Types_8_8_8_01_4_01_4__inherit__graph.png
share/doc/glibmm-2.4/reference/html/classGlib_1_1Variant_3_01std_1_1vector_3_01Glib_1_1DBusObjectPathString_01_4_01_4-members.html
share/doc/glibmm-2.4/reference/html/classGlib_1_1Variant_3_01std_1_1vector_3_01Glib_1_1DBusObjectPathString_01_4_01_4.html
share/doc/glibmm-2.4/reference/html/classGlib_1_1Variant_3_01std_1_1vector_3_01Glib_1_1ustring_01_4_01_4-members.html
share/doc/glibmm-2.4/reference/html/classGlib_1_1Variant_3_01std_1_1vector_3_01Glib_1_1ustring_01_4_01_4.html
share/doc/glibmm-2.4/reference/html/classGlib_1_1Variant_3_01std_1_1vector_3_01Glib_1_1ustring_01_4_01_4__inherit__graph.png
Expand All @@ -1270,6 +1286,7 @@ share/doc/glibmm-2.4/reference/html/classGlib_1_1ustring-members.html
share/doc/glibmm-2.4/reference/html/classGlib_1_1ustring.html
share/doc/glibmm-2.4/reference/html/classGlib_1_1ustring__Iterator-members.html
share/doc/glibmm-2.4/reference/html/classGlib_1_1ustring__Iterator.html
share/doc/glibmm-2.4/reference/html/classGlib_1_1ustring__inherit__graph.png
share/doc/glibmm-2.4/reference/html/classes.html
share/doc/glibmm-2.4/reference/html/closed.png
share/doc/glibmm-2.4/reference/html/deprecated.html
Expand All @@ -1284,6 +1301,7 @@ share/doc/glibmm-2.4/reference/html/examples.html
share/doc/glibmm-2.4/reference/html/folderclosed.png
share/doc/glibmm-2.4/reference/html/folderopen.png
share/doc/glibmm-2.4/reference/html/functions.html
share/doc/glibmm-2.4/reference/html/functions_0x7e.html
share/doc/glibmm-2.4/reference/html/functions_b.html
share/doc/glibmm-2.4/reference/html/functions_c.html
share/doc/glibmm-2.4/reference/html/functions_d.html
Expand Down Expand Up @@ -1315,6 +1333,7 @@ share/doc/glibmm-2.4/reference/html/functions_eval_w.html
share/doc/glibmm-2.4/reference/html/functions_eval_y.html
share/doc/glibmm-2.4/reference/html/functions_f.html
share/doc/glibmm-2.4/reference/html/functions_func.html
share/doc/glibmm-2.4/reference/html/functions_func_0x7e.html
share/doc/glibmm-2.4/reference/html/functions_func_b.html
share/doc/glibmm-2.4/reference/html/functions_func_c.html
share/doc/glibmm-2.4/reference/html/functions_func_d.html
Expand All @@ -1339,7 +1358,6 @@ share/doc/glibmm-2.4/reference/html/functions_func_v.html
share/doc/glibmm-2.4/reference/html/functions_func_w.html
share/doc/glibmm-2.4/reference/html/functions_func_y.html
share/doc/glibmm-2.4/reference/html/functions_func_z.html
share/doc/glibmm-2.4/reference/html/functions_func_~.html
share/doc/glibmm-2.4/reference/html/functions_g.html
share/doc/glibmm-2.4/reference/html/functions_h.html
share/doc/glibmm-2.4/reference/html/functions_i.html
Expand Down Expand Up @@ -1377,7 +1395,6 @@ share/doc/glibmm-2.4/reference/html/functions_vars.html
share/doc/glibmm-2.4/reference/html/functions_w.html
share/doc/glibmm-2.4/reference/html/functions_y.html
share/doc/glibmm-2.4/reference/html/functions_z.html
share/doc/glibmm-2.4/reference/html/functions_~.html
share/doc/glibmm-2.4/reference/html/graph_legend.html
share/doc/glibmm-2.4/reference/html/graph_legend.png
share/doc/glibmm-2.4/reference/html/group__Base64.html
Expand Down Expand Up @@ -1524,6 +1541,8 @@ share/doc/glibmm-2.4/reference/html/inherit_graph_98.png
share/doc/glibmm-2.4/reference/html/inherit_graph_99.png
share/doc/glibmm-2.4/reference/html/inherits.html
share/doc/glibmm-2.4/reference/html/jquery.js
share/doc/glibmm-2.4/reference/html/menu.js
share/doc/glibmm-2.4/reference/html/menudata.js
share/doc/glibmm-2.4/reference/html/modules.html
share/doc/glibmm-2.4/reference/html/namespaceGio.html
share/doc/glibmm-2.4/reference/html/namespaceGio_1_1DBus.html
Expand Down Expand Up @@ -1625,6 +1644,8 @@ share/doc/glibmm-2.4/reference/html/since_2_44.html
share/doc/glibmm-2.4/reference/html/since_2_46.html
share/doc/glibmm-2.4/reference/html/since_2_48.html
share/doc/glibmm-2.4/reference/html/since_2_50.html
share/doc/glibmm-2.4/reference/html/since_2_52.html
share/doc/glibmm-2.4/reference/html/since_2_54.html
share/doc/glibmm-2.4/reference/html/since_2_6.html
share/doc/glibmm-2.4/reference/html/since_2_8.html
share/doc/glibmm-2.4/reference/html/splitbar.png
Expand Down
10 changes: 5 additions & 5 deletions devel/glibmm/distinfo
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.51 2017/04/25 18:11:58 adam Exp $
$NetBSD: distinfo,v 1.52 2017/11/24 15:14:50 wiz Exp $

SHA1 (glibmm-2.50.1.tar.xz) = 07ceb53b995f10ae0f9c572fb11febaa3e33d669
RMD160 (glibmm-2.50.1.tar.xz) = 47f6ce43d2883f0ef15c570edf0bf63faee9274c
SHA512 (glibmm-2.50.1.tar.xz) = 4f25c75c1628ca2f4db1c29cebc63187d372603066b06aa6a66c6da792f9e02cb4a413e41f058a81e2d5a2b38d625de13df76115b278f010ce2fc493fe6e6bbb
Size (glibmm-2.50.1.tar.xz) = 6444576 bytes
SHA1 (glibmm-2.54.1.tar.xz) = 8246192adc17d8e96ae4d2b3b555f31c282e9188
RMD160 (glibmm-2.54.1.tar.xz) = b83f6260a70e3ed10918d96dea37c6fc7bf40054
SHA512 (glibmm-2.54.1.tar.xz) = 94f2a4d6972684e25e38ff2e6bcfc1e9c5e4d096856d3419320c14166e27e26b1ad69be434337e9b70c23842989988113521aae7a800ef2f29e81f1ae6c25a13
Size (glibmm-2.54.1.tar.xz) = 6837384 bytes
SHA1 (patch-glib_glibmm_ustring.cc) = b4fc8965bc5fc1bcc5ea1ac377a13b22659557ee

0 comments on commit 9901225

Please sign in to comment.