Skip to content

Commit

Permalink
assimp: update to 5.2.5.
Browse files Browse the repository at this point in the history
What's Changed

    Add unittest to reproduce undefined behavior by @kimkulling in #4532
    Cleanups by @kimkulling in #4537
    Link static linkage for std_image. by @kimkulling in #4478
    fix msvc warnings-as-errors by @Gargaj in #4549
    Remove dll-export tags from static library builds. by @Underdisc in #4555
    Fix Import a specific FBX model will freeze the app #4395 by @Nor-s in #4554
    Create SECURITY.md by @kimkulling in #4565
    Pragma warnings cause build fail with MinGW by @ethaninfinity in #4564
    Fixed FBXConverter build error when using double precision by @matthewclendening in #4546
    Fix possible nullptr exception by @kimkulling in #4567
    [Experimental] New skeleton container for bones by @kimkulling in #4552
    Add support for GCC v12 by @PercentBoat4164 in #4578
    Remove unused variable. by @kovacsv in #4584
    Infinite loop on bad import files by @tanolino in #4534
    Utilize AI_CONFIG_IMPORT_REMOVE_EMPTY_BONES flag for Collada meshes. by @onurtore in #4585
    Fix Windows 32-bit builds by @Gargaj in #4581
    Fix GNUC check on Windows by @hgdagon in #4542
    Update the name of the package by @kimkulling in #4595
    Kimkulling/fix invalid opengex token match by @kimkulling in #4596
    Disable build for tools per default by @kimkulling in #4598
    Use mingw.include by @kimkulling in #4601
    Fix a memory leak by @kimkulling in #4605
    Try to fix issue 4238 by @kimkulling in #4609
    Fix nested animation name being lost in Collada by @luca-della-vedova in #4597
    chore: Included GitHub actions in the dependabot config by @naveensrinivasan in #4569
    Fix possible bad_alloc exception for an invalid file by @kimkulling in #4614
    Bump JesseTG/rm from 1.0.2 to 1.0.3 by @dependabot in #4613
    Bump actions/cache from 2 to 3 by @dependabot in #4612
    Kimkulling/fix texture loading 3MF, reladed issue-4568 by @kimkulling in #4619
    Bump actions/upload-artifact from 2 to 3 by @dependabot in #4610
    Bump actions/checkout from 2 to 3 by @dependabot in #4611
    I ran into an error while processing colored binary stl. Just a type but it better be fixed by @blackhorse-reddog in #4541
    Remove assertion test by @kimkulling in #4627
    Fix memory leak in D3MFOpcPackage by @kimkulling in #4629
    Fix typo in installation instructions for ubuntu. by @hectorpiteau in #4621
    Build fix for compiling against minizip. by @robertosfield in #4631
    Fix stl for over 4 GB by @tanolino in #4630
    Fix uninitialized variable. by @kimkulling in #4642
    Fixes Crash in Assimp::ObjFileMtlImporter::getFloatValue by @sashashura in #4647
    Fixes Heap-buffer-overflow in Assimp::ObjFileParser::getFace by @sashashura in #4646
    Fixes Heap-buffer-overflow in std::__1::basic_string<char, std::__1::… by @sashashura in #4645
    Fixes Heap-use-after-free in Assimp::DXFImporter::ExpandBlockReferences by @sashashura in #4644
    Fixes Heap-buffer-overflow in SuperFastHash by @sashashura in #4643
    ColladaParser - Store sid in mSID field by @luca-della-vedova in #4538
    Fix mingw include in assimp_cmd.rc by @Koekto-code in #4635
    Fix warnings that are causing build fails with specific build flags by @enginmanap in #4632
    Update version tag by @waebbl in #4656
    Improvements and optimizations for the obj-parsers. by @kimkulling in #4666
    Experiment: try to enable parallel build by @kimkulling in #4669
    Fixed typo by @Fiskmans in #4668
    Use [[fallthrough]]; to mark whished fallthroughs by @kimkulling in #4673
    Kimkulling/do not add dot when the extension is empty issue 4670 by @kimkulling in #4674
    Fixes Heap-buffer-overflow READ in Assimp::ASE::Parser::ParseLV1SoftSkinBlock by @sashashura in #4680
    Use unqualified uint32_t everywhere in FBXBinaryTokenizer by @villevoutilainen in #4678
    Fix problems setting DirectX_LIBRARY by @Koekto-code in #4681
    Added support for more bone weights in GLTF2 by @Promit in #4453
    (Mostly) Blender fixes by @turol in #4679
    [WIP] Use ai_Real to write correct accuracy by @kimkulling in #4697
    SMD fixes by @turol in #4699
    Remove exception on glTF 2.0 loading by @vkaytsanov in #4693
    Fix out-of-bounds reads in X3D importer by @turol in #4701
    Apply the modernize-use-emplace clang-tidy rule by @Skylion007 in #4700
    The Wrong object is created here! by @JG-Adams in #4704
    [WIP] Code cleanup and some new unittests for edge-cases. by @kimkulling in #4705
    clang-tidy: explicitly default all empty ctors and dtors by @Skylion007 in #4703
    fix vertices being joined duplicating weights by @Gargaj in #4707
    add missing light data to assbin import/export by @Gargaj in #4702
    Fix aiBone.mOffsetMatrix documentation by @ChrisBlueStone in #4713
    Minor obj export bugfix by @HiMemX in #4716
    Kimkulling/cleanup after reviewing by @kimkulling in #4715
  • Loading branch information
0-wiz-0 committed Apr 26, 2023
1 parent c64e7da commit ae00857
Show file tree
Hide file tree
Showing 3 changed files with 8 additions and 9 deletions.
4 changes: 2 additions & 2 deletions multimedia/assimp/Makefile
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.7 2023/03/02 16:25:49 tnn Exp $
# $NetBSD: Makefile,v 1.8 2023/04/26 19:32:56 wiz Exp $

DISTNAME= assimp-5.2.4
DISTNAME= assimp-5.2.5
CATEGORIES= multimedia
MASTER_SITES= ${MASTER_SITE_GITHUB:=assimp/}
GITHUB_TAG= v${PKGVERSION_NOREV}
Expand Down
5 changes: 2 additions & 3 deletions multimedia/assimp/PLIST
Original file line number Diff line number Diff line change
@@ -1,5 +1,4 @@
@comment $NetBSD: PLIST,v 1.3 2022/04/14 13:20:42 nros Exp $
bin/assimp
@comment $NetBSD: PLIST,v 1.4 2023/04/26 19:32:56 wiz Exp $
include/assimp/Base64.hpp
include/assimp/BaseImporter.h
include/assimp/Bitmap.h
Expand Down Expand Up @@ -94,5 +93,5 @@ lib/cmake/assimp-5.2/assimpTargets-noconfig.cmake
lib/cmake/assimp-5.2/assimpTargets.cmake
lib/libassimp.so
lib/libassimp.so.5
lib/libassimp.so.5.2.0
lib/libassimp.so.5.2.4
lib/pkgconfig/assimp.pc
8 changes: 4 additions & 4 deletions multimedia/assimp/distinfo
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.9 2022/08/10 01:00:08 charlotte Exp $
$NetBSD: distinfo,v 1.10 2023/04/26 19:32:56 wiz Exp $

BLAKE2s (assimp-5.2.4.tar.gz) = 53fbd93476ace29045fde352551418a89c54511aaa2caa42c5c3668c0bfca0ed
SHA512 (assimp-5.2.4.tar.gz) = ee988b1806b46c78f97bb5b25237a3f56a7028ed37898fb9b243e379e29e8bfd29e4dffc616566941ed9bdcf502bd30568904ad2ef2ef7d0f63b40daefdc66bf
Size (assimp-5.2.4.tar.gz) = 49613683 bytes
BLAKE2s (assimp-5.2.5.tar.gz) = 819de5b93729a70ca98683a8604e2b0e7eef8e04bb841905167bd0a19fda42d8
SHA512 (assimp-5.2.5.tar.gz) = ac0dc4243f9d1ff077966f0037187b4374075ac97e75e1a3cd6bdc1caf5f8e4d40953d9a8a316480969c09524d87daa9d3ed75e6ac6f037dd5b1c5f25fce3afb
Size (assimp-5.2.5.tar.gz) = 49543936 bytes
SHA1 (patch-contrib_zip_src_zip.h) = 1eac9382ac0536d4ede0b9c4f9e72c7ef1dfbf63

0 comments on commit ae00857

Please sign in to comment.