Skip to content
This repository has been archived by the owner on Oct 25, 2022. It is now read-only.

Commit

Permalink
[update to 4.0.1] Upgrade tox and virtualenv to ensure that environme…
Browse files Browse the repository at this point in the history
…nts get recent pips

Jason R. Coombs (26):
      Add black config, pre-commit including black, check code with black.
      Suppress E117 as workaround for PyCQA/pycodestyle#836
      Amend skeleton documentation to expand on the value of the approach.
      Remove sudo declaration in Travis config.
      Enable tox-pip-extensions ext_venv_update if available. Fixes jaraco/skeleton#6
      Rely on tox 3.2 and pip 10 or later for all builds
      It adds no value to add a pip requirement for the tox install
      Pin to pip 19.0 for now for pypa/pip#6434.
      Revert "Pin to pip 19.0 for now for pypa/pip#6434."
      Only install and invoke pytest-black on Python 3
      Use pytest-black-multipy to enable simple support for pytest-black where available. Ref pytest-dev/pytest#5272.
      Update skeleton documentation to reflect black adoption.
      Add support for automatic publishing of release notes
      Use technique for environment passing matching that found in jaraco/skeleton
      Rely on twine 1.13 or later
      Upgrade tox and virtualenv to ensure that environments get recent pips
      Define passenv in tox release section. Rely on __token__ for default username.
      Update docs to reflect changes to deployment.
      Move Tidelift token into Travis configuration
      Switch to semver for versioning, starting with the 4.0.0 release. Fixes #44.
      Rely on setuptools_scm to derive package version from SCM tags.
      Use 'v' prefix to match semver design.
      Fade to black
      Update badge URL
      Use template when publishing release notes to override the reference to read the docs, not used here.
      Update changelog
  • Loading branch information
fenrus75 committed Sep 10, 2019
1 parent 5d2d1ab commit 2cd76ea
Show file tree
Hide file tree
Showing 8 changed files with 21 additions and 11 deletions.
3 changes: 3 additions & 0 deletions .gitignore
Original file line number Diff line number Diff line change
Expand Up @@ -10,6 +10,9 @@ build.log.round*
*.tgz
!*.tar.*.*
*.zip
*.jar
*.pom
*.xml
commitmsg
results/
rpms/
Expand Down
2 changes: 1 addition & 1 deletion Makefile
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
PKG_NAME := configparser
URL = https://files.pythonhosted.org/packages/b1/83/fa54eee6643ffb30ab5a5bebdb523c697363658e46b85729e3d587a3765e/configparser-3.8.1.tar.gz
URL = https://files.pythonhosted.org/packages/c4/75/0ed2711aab826e48baff301f7a3d045e23a562ccfe1ff992be935f02ac9f/configparser-4.0.1.tar.gz
ARCHIVES =

include ../common/Makefile.common
3 changes: 3 additions & 0 deletions buildreq_cache
Original file line number Diff line number Diff line change
@@ -0,0 +1,3 @@
4.0.1
setuptools
setuptools_scm-python
14 changes: 8 additions & 6 deletions configparser.spec
Original file line number Diff line number Diff line change
Expand Up @@ -3,10 +3,10 @@
# Generated by: autospec.py
#
Name : configparser
Version : 3.8.1
Release : 47
URL : https://files.pythonhosted.org/packages/b1/83/fa54eee6643ffb30ab5a5bebdb523c697363658e46b85729e3d587a3765e/configparser-3.8.1.tar.gz
Source0 : https://files.pythonhosted.org/packages/b1/83/fa54eee6643ffb30ab5a5bebdb523c697363658e46b85729e3d587a3765e/configparser-3.8.1.tar.gz
Version : 4.0.1
Release : 48
URL : https://files.pythonhosted.org/packages/c4/75/0ed2711aab826e48baff301f7a3d045e23a562ccfe1ff992be935f02ac9f/configparser-4.0.1.tar.gz
Source0 : https://files.pythonhosted.org/packages/c4/75/0ed2711aab826e48baff301f7a3d045e23a562ccfe1ff992be935f02ac9f/configparser-4.0.1.tar.gz
Summary : Updated configparser from Python 3.7 for Python 2.6+.
Group : Development/Tools
License : MIT
Expand All @@ -17,7 +17,9 @@ BuildRequires : buildreq-distutils3
BuildRequires : pluggy
BuildRequires : py-python
BuildRequires : pytest
BuildRequires : setuptools
BuildRequires : setuptools-legacypython
BuildRequires : setuptools_scm-python
BuildRequires : tox
BuildRequires : virtualenv

Expand Down Expand Up @@ -52,14 +54,14 @@ python3 components for the configparser package.


%prep
%setup -q -n configparser-3.8.1
%setup -q -n configparser-4.0.1

%build
export http_proxy=http://127.0.0.1:9/
export https_proxy=http://127.0.0.1:9/
export no_proxy=localhost,127.0.0.1,0.0.0.0
export LANG=C.UTF-8
export SOURCE_DATE_EPOCH=1565578380
export SOURCE_DATE_EPOCH=1568150662
# -Werror is for werrorists
export GCC_IGNORE_WERROR=1
export CFLAGS="$CFLAGS -fno-lto "
Expand Down
4 changes: 3 additions & 1 deletion options.conf
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
[package]
name = configparser
url = https://files.pythonhosted.org/packages/b1/83/fa54eee6643ffb30ab5a5bebdb523c697363658e46b85729e3d587a3765e/configparser-3.8.1.tar.gz
url = https://files.pythonhosted.org/packages/c4/75/0ed2711aab826e48baff301f7a3d045e23a562ccfe1ff992be935f02ac9f/configparser-4.0.1.tar.gz
archives =
giturl = https://github.com/jaraco/configparser.git

Expand Down Expand Up @@ -33,6 +33,8 @@ insecure_build = false
keepstatic = false
# do not require autostart subpackage
no_autostart = false
# do not generate debuginfo for this package
nodebug = false
# disable stripping binaries
nostrip = false
# optimize build for size over speed
Expand Down
2 changes: 1 addition & 1 deletion release
Original file line number Diff line number Diff line change
@@ -1 +1 @@
47
48
2 changes: 1 addition & 1 deletion upstream
Original file line number Diff line number Diff line change
@@ -1 +1 @@
675549f76a63c4d9216013b1c1f8370cd5c43a87/configparser-3.8.1.tar.gz
a3e5382026584dc03cbc018ac2ee72e51a7f8c93/configparser-4.0.1.tar.gz
2 changes: 1 addition & 1 deletion versions
Original file line number Diff line number Diff line change
@@ -1 +1 @@
3.8.1
4.0.1

0 comments on commit 2cd76ea

Please sign in to comment.