Skip to content

Commit

Permalink
pypi-jaraco.collections: Autospec creation for update from version 5.…
Browse files Browse the repository at this point in the history
…0.1 to version 5.1.0

Anderson Bravalheri (1):
      Add `--fix`  flag to ruff pre-commit hook for automatic suggestion of fixes (jaraco/skeleton#140)

Avasam (4):
      Add Protocols, remove @overload, from `.coveragerc` `exclude_also` (jaraco/skeleton#135)
      Loosen restrictions on mypy (jaraco/skeleton#136)
      Pass mypy and link issues
      Fully typed `RangeMap` and avoid complete iterations to find matches (#16)

Bartosz Sławecki (1):
      Move project metadata to `pyproject.toml` (jaraco/skeleton#122)

Dimitri Papadopoulos Orfanos (3):
      "preserve" does not require preview any more (jaraco/skeleton#133)
      Enforce ruff/Perflint rule PERF401 (jaraco/skeleton#132)
      Update to the latest ruff version (jaraco/skeleton#137)

Jason R. Coombs (14):
      Pin against pytest 8.1.x due to pytest-dev/pytest#12194.
      Migrated config to pyproject.toml using jaraco.develop.migrate-config and ini2toml.
      Allow macos on Python 3.8 to fail as GitHub CI has dropped support.
      Move project.urls to appear in the order that ini2toml generates it. Remove project.scripts.
      Revert "Allow macos on Python 3.8 to fail as GitHub CI has dropped support."
      Rename extras to align with core metadata spec.
      Prefer "Source" to "Homepage" for the repository label.
      Exclude pytest-ruff (and thus ruff), which cannot build on cygwin.
      Re-enable preview, this time not for one specific feature, but for all features in preview.
      Split the test dependencies into four classes (test, cover, type, check). (jaraco/skeleton#139)
      Add upstream and local sections for 'type' extra, since many projects will have 'types-*' dependencies.
      Disable mypy for now. Ref jaraco/skeleton#143
      Finalize
      Remove unsupported attribution. See jaraco/skeleton#144.
  • Loading branch information
fenrus75 committed Aug 25, 2024
1 parent 18faf28 commit faf0456
Show file tree
Hide file tree
Showing 5 changed files with 19 additions and 15 deletions.
2 changes: 1 addition & 1 deletion Makefile
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
PKG_NAME := pypi-jaraco.collections
URL = https://files.pythonhosted.org/packages/53/87/93c02af0d3ca4c0195242ab74ba6fc4f1f32046e17d5494abdebf7827322/jaraco.collections-5.0.1.tar.gz
URL = https://files.pythonhosted.org/packages/8c/ed/3f0ef2bcf765b5a3d58ecad8d825874a3af1e792fa89f89ad79f090a4ccc/jaraco_collections-5.1.0.tar.gz
ARCHIVES =

include ../common/Makefile.common
6 changes: 5 additions & 1 deletion options.conf
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
[package]
name = pypi-jaraco.collections
url = https://files.pythonhosted.org/packages/53/87/93c02af0d3ca4c0195242ab74ba6fc4f1f32046e17d5494abdebf7827322/jaraco.collections-5.0.1.tar.gz
url = https://files.pythonhosted.org/packages/8c/ed/3f0ef2bcf765b5a3d58ecad8d825874a3af1e792fa89f89ad79f090a4ccc/jaraco_collections-5.1.0.tar.gz
archives =
giturl = https://github.com/jaraco/jaraco.collections/
domain =
Expand All @@ -17,6 +17,8 @@ allow_test_failures = false
asneeded = false
# this package is trusted enough to automatically update (used by other tools)
autoupdate = true
# try to use mock short circuit to avoid full rebuilds
avoid_rebuild = false
# extend flags with '-std=gnu++98
broken_c++ = false
# disable parallelization during build
Expand Down Expand Up @@ -71,6 +73,8 @@ use_avx512 = false
use_clang = false
# configure build for lto
use_lto = true
# use ninja build files
use_ninja = false
# require package verification for build
verify_required = false

22 changes: 11 additions & 11 deletions pypi-jaraco.collections.spec
Original file line number Diff line number Diff line change
Expand Up @@ -2,14 +2,14 @@
# This file is auto-generated. DO NOT EDIT
# Generated by: autospec.py
# Using build pattern: pyproject
# autospec version: v10
# autospec commit: 5905be9
# autospec version: v18
# autospec commit: f35655a
#
Name : pypi-jaraco.collections
Version : 5.0.1
Release : 47
URL : https://files.pythonhosted.org/packages/53/87/93c02af0d3ca4c0195242ab74ba6fc4f1f32046e17d5494abdebf7827322/jaraco.collections-5.0.1.tar.gz
Source0 : https://files.pythonhosted.org/packages/53/87/93c02af0d3ca4c0195242ab74ba6fc4f1f32046e17d5494abdebf7827322/jaraco.collections-5.0.1.tar.gz
Version : 5.1.0
Release : 48
URL : https://files.pythonhosted.org/packages/8c/ed/3f0ef2bcf765b5a3d58ecad8d825874a3af1e792fa89f89ad79f090a4ccc/jaraco_collections-5.1.0.tar.gz
Source0 : https://files.pythonhosted.org/packages/8c/ed/3f0ef2bcf765b5a3d58ecad8d825874a3af1e792fa89f89ad79f090a4ccc/jaraco_collections-5.1.0.tar.gz
Summary : Collection objects similar to those in stdlib by jaraco
Group : Development/Tools
License : MIT
Expand Down Expand Up @@ -61,18 +61,18 @@ python3 components for the pypi-jaraco.collections package.


%prep
%setup -q -n jaraco.collections-5.0.1
cd %{_builddir}/jaraco.collections-5.0.1
%setup -q -n jaraco_collections-5.1.0
cd %{_builddir}/jaraco_collections-5.1.0
pushd ..
cp -a jaraco.collections-5.0.1 buildavx2
cp -a jaraco_collections-5.1.0 buildavx2
popd

%build
export http_proxy=http://127.0.0.1:9/
export https_proxy=http://127.0.0.1:9/
export no_proxy=localhost,127.0.0.1,0.0.0.0
export LANG=C.UTF-8
export SOURCE_DATE_EPOCH=1713037688
export SOURCE_DATE_EPOCH=1724626334
export GCC_IGNORE_WERROR=1
export AR=gcc-ar
export RANLIB=gcc-ranlib
Expand Down Expand Up @@ -117,7 +117,7 @@ LDFLAGS="$CLEAR_INTERMEDIATE_LDFLAGS"
export MAKEFLAGS=%{?_smp_mflags}
rm -rf %{buildroot}
mkdir -p %{buildroot}/usr/share/package-licenses/pypi-jaraco.collections
cp %{_builddir}/jaraco.collections-%{version}/LICENSE %{buildroot}/usr/share/package-licenses/pypi-jaraco.collections/0445ed0f69910eeaee036f09a39a13c6e1f37e12 || :
cp %{_builddir}/jaraco_collections-%{version}/LICENSE %{buildroot}/usr/share/package-licenses/pypi-jaraco.collections/0445ed0f69910eeaee036f09a39a13c6e1f37e12 || :
python3 -m installer --destdir=%{buildroot} dist/*.whl
echo ----[ mark ]----
cat %{buildroot}/usr/lib/python3*/site-packages/*/requires.txt || :
Expand Down
2 changes: 1 addition & 1 deletion release
Original file line number Diff line number Diff line change
@@ -1 +1 @@
47
48
2 changes: 1 addition & 1 deletion upstream
Original file line number Diff line number Diff line change
@@ -1 +1 @@
acb5174ef037d545a8b1a2f3537911f284ae07c7/jaraco.collections-5.0.1.tar.gz
3f9e7503700952db664f8b1e84a84debbc81c631/jaraco_collections-5.1.0.tar.gz

0 comments on commit faf0456

Please sign in to comment.