Skip to content

Commit

Permalink
pypi-setuptools: Autospec creation for update from version 70.3.0 to …
Browse files Browse the repository at this point in the history
…version 71.0.0

Avasam (2):
      Rewrite marker evaluation to address two type check failures.
      Update `Requirement.__contains__` type spec to accept `UnparsedVersion`.

Dimitri Papadopoulos (2):
      Ignore ruff/tryceratops rule TRY003
      Fix 92989c2i / #4450

Jason R. Coombs (34):
      Declare the dependencies and update vendoring routine for setuptools (only) to simply install the dependencies to the _vendor folder.
      Specify environment-conditional transitive deps.
      Import dependencies naturally and ensure they're available by appending the vendor dir to sys.path.
      Re-vendor setuptools packages.
      Remove importlib_metadata workaround.
      Remove setuptools.extern
      Remove check-extern env in tox.
      Update vendoring routine for pkg_resources to simply install the dependencies to the _vendor folder.
      Import dependencies naturally and ensure they're available by appending the vendor dir to sys.path.
      Re-vendor pkg_resources packages.
      Remove obsolete 'rewrite' functionality from vendored script.
      Update auto-detect the minimum python version needed for vendored packages.
      Refresh vendored dependencies.
      Consolidate vendored packages in the setuptools package.
      Remove pkg_resources.extern.
      Clean up references to extern modules.
      Add news fragment.
      Suppress type errors around wheel.
      Fix type error in vendored tool.
      Fix incorrect type declaration in _python_requires.
      Fix type errors in pkg_resources, now that packaging types are recognized properly.
      Suppress coverage errors.
      Moved the dependencies to a 'core' extra to avoid dangers with cyclic dependencies at build time.
      Ensure that package data from vendored packages gets installed.
      Explicitly declare the 'core' extra as 'for informational purposes'
      Rely on os.path.join and os.path.dirname when adding the vendored path and only add it if it's not already present.
      Resolve a version from an item, addressing missed `arg-type` check.
      Pin pytest-ruff on Windows.
      Move workaround for #3921 to the local section, restoring upstream to match upstream.
      Exclude pytest-ruff (and thus ruff), which cannot build on cygwin.
      Bump version: 70.3.0 → 71.0.0
      👹 Feed the hobgoblins (delint).
      Update intersphinx link to point to redirected target.
      Pin Sphinx to <7.4 as workaround for sphinx-doc/sphinx#12613. Closes #4474.

Marco Treglia (1):
      Rename arguments on _EditableFinder and _EditableNamespaceFinder
  • Loading branch information
fenrus75 committed Jul 18, 2024
1 parent 24480be commit 6065cc7
Show file tree
Hide file tree
Showing 5 changed files with 13 additions and 22 deletions.
2 changes: 1 addition & 1 deletion Makefile
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
PKG_NAME := pypi-setuptools
URL = https://files.pythonhosted.org/packages/65/d8/10a70e86f6c28ae59f101a9de6d77bf70f147180fbf40c3af0f64080adc3/setuptools-70.3.0.tar.gz
URL = https://files.pythonhosted.org/packages/32/37/8751819aebb61ff15cc438e9d80d7b32d6cef4f266a1145a7037cbbfd693/setuptools-71.0.0.tar.gz
ARCHIVES =

include ../common/Makefile.common
2 changes: 1 addition & 1 deletion options.conf
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
[package]
name = pypi-setuptools
url = https://files.pythonhosted.org/packages/65/d8/10a70e86f6c28ae59f101a9de6d77bf70f147180fbf40c3af0f64080adc3/setuptools-70.3.0.tar.gz
url = https://files.pythonhosted.org/packages/32/37/8751819aebb61ff15cc438e9d80d7b32d6cef4f266a1145a7037cbbfd693/setuptools-71.0.0.tar.gz
archives =
giturl = https://github.com/pypa/setuptools.git
domain =
Expand Down
27 changes: 9 additions & 18 deletions pypi-setuptools.spec
Original file line number Diff line number Diff line change
Expand Up @@ -3,13 +3,13 @@
# Generated by: autospec.py
# Using build pattern: pyproject
# autospec version: v16
# autospec commit: b858a2a
# autospec commit: 9f33e63
#
Name : pypi-setuptools
Version : 70.3.0
Release : 327
URL : https://files.pythonhosted.org/packages/65/d8/10a70e86f6c28ae59f101a9de6d77bf70f147180fbf40c3af0f64080adc3/setuptools-70.3.0.tar.gz
Source0 : https://files.pythonhosted.org/packages/65/d8/10a70e86f6c28ae59f101a9de6d77bf70f147180fbf40c3af0f64080adc3/setuptools-70.3.0.tar.gz
Version : 71.0.0
Release : 328
URL : https://files.pythonhosted.org/packages/32/37/8751819aebb61ff15cc438e9d80d7b32d6cef4f266a1145a7037cbbfd693/setuptools-71.0.0.tar.gz
Source0 : https://files.pythonhosted.org/packages/32/37/8751819aebb61ff15cc438e9d80d7b32d6cef4f266a1145a7037cbbfd693/setuptools-71.0.0.tar.gz
Summary : Easily download, build, install, upgrade, and uninstall Python packages
Group : Development/Tools
License : MIT Python-2.0 ZPL-2.0
Expand Down Expand Up @@ -63,18 +63,18 @@ python3 components for the pypi-setuptools package.


%prep
%setup -q -n setuptools-70.3.0
cd %{_builddir}/setuptools-70.3.0
%setup -q -n setuptools-71.0.0
cd %{_builddir}/setuptools-71.0.0
pushd ..
cp -a setuptools-70.3.0 buildavx2
cp -a setuptools-71.0.0 buildavx2
popd

%build
export http_proxy=http://127.0.0.1:9/
export https_proxy=http://127.0.0.1:9/
export no_proxy=localhost,127.0.0.1,0.0.0.0
export LANG=C.UTF-8
export SOURCE_DATE_EPOCH=1720543518
export SOURCE_DATE_EPOCH=1721318652
export GCC_IGNORE_WERROR=1
export AR=gcc-ar
export RANLIB=gcc-ranlib
Expand Down Expand Up @@ -133,15 +133,6 @@ FCFLAGS="$CLEAR_INTERMEDIATE_FCFLAGS -march=x86-64-v3 "
LDFLAGS="$CLEAR_INTERMEDIATE_LDFLAGS -march=x86-64-v3 "
python3 -m installer --destdir=%{buildroot}-v3 dist/*.whl
popd
## Remove excluded files
rm -f %{buildroot}*/usr/lib/python3.12/site-packages/setuptools/cli-32.exe
rm -f %{buildroot}*/usr/lib/python3.12/site-packages/setuptools/cli-64.exe
rm -f %{buildroot}*/usr/lib/python3.12/site-packages/setuptools/cli-arm64.exe
rm -f %{buildroot}*/usr/lib/python3.12/site-packages/setuptools/cli.exe
rm -f %{buildroot}*/usr/lib/python3.12/site-packages/setuptools/gui-32.exe
rm -f %{buildroot}*/usr/lib/python3.12/site-packages/setuptools/gui-64.exe
rm -f %{buildroot}*/usr/lib/python3.12/site-packages/setuptools/gui-arm64.exe
rm -f %{buildroot}*/usr/lib/python3.12/site-packages/setuptools/gui.exe
## install_append content
mkdir -p %{buildroot}/usr/bin
echo "#!/bin/sh" > %{buildroot}/usr/bin/easy_install_is_deprecated
Expand Down
2 changes: 1 addition & 1 deletion release
Original file line number Diff line number Diff line change
@@ -1 +1 @@
327
328
2 changes: 1 addition & 1 deletion upstream
Original file line number Diff line number Diff line change
@@ -1 +1 @@
527675a6ed0d160f0bf3fc60752f8656b41bb241/setuptools-70.3.0.tar.gz
053f85800c1e2ff91b16f77405a8a8b5c78dfc74/setuptools-71.0.0.tar.gz

0 comments on commit 6065cc7

Please sign in to comment.