Skip to content

Commit

Permalink
python3: Fix implement hadling ".mc" files
Browse files Browse the repository at this point in the history
  • Loading branch information
Alexpux committed Jul 30, 2019
1 parent 240d923 commit 1912c5b
Show file tree
Hide file tree
Showing 2 changed files with 10 additions and 1 deletion.
Original file line number Diff line number Diff line change
Expand Up @@ -29,3 +29,12 @@
else: # for other files use the C-compiler
try:
self.spawn(self.compiler_so + cc_args + [src, '-o', obj] +
@@ -261,7 +283,7 @@
ext_normcase = os.path.normcase(ext)
if ext_normcase in ['.rc','.res']:
ext = ext_normcase
- if ext not in (self.src_extensions + ['.rc','.res']):
+ if ext not in (self.src_extensions + ['.rc', '.res', '.mc']):
raise UnknownFileError("unknown file type '%s' (from '%s')" % \
(ext, src_name))
base = os.path.splitdrive(base)[1] # Chop off the drive
2 changes: 1 addition & 1 deletion mingw-w64-python3/PKGBUILD
Original file line number Diff line number Diff line change
Expand Up @@ -578,5 +578,5 @@ sha256sums=('fb799134b868199930b75f26678f18932214042639cd52b16da7fd134cd9b13f'
'6ee9095eb78c88c205e225c0e8a0b169f5498c62d6531a2d3199450d0fe895e5'
'09c9f8e14c1f54a1242f4db21af4a014d414fd72b3a92241842965f550f75472'
'180fd0a8f4d24ed7e50eb7916548f7fe398811a76063b043efdf7ab18602c55b'
'48852b3c463d3a5b614ecc2491a480cb2cdc1cc4d6b62800cb999833a269b6fa'
'f376056f995878bfd50a30e3ec3f34d9a598504062395fb1aff1518e2fa83abf'
'821402ddaef92140c70041b007bcf15e1cd5fe0fdb9f4f612da868382cc24585')

0 comments on commit 1912c5b

Please sign in to comment.